PtokaX wiki

Hub (server) for Direct Connect

User Tools

Site Tools


guides:freebsd

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
Last revision Both sides next revision
guides:freebsd [10/07/2015 11:58]
ppk b502
guides:freebsd [12/09/2015 22:54]
ppk 0.5.2.1
Line 1: Line 1:
 ====== Compile on FreeBSD ====== ====== Compile on FreeBSD ======
-This guide was tested on clean installation of [[http://www.freebsd.org|FreeBSD]] 10.1.\\+This guide was tested on clean installation of [[http://www.freebsd.org|FreeBSD]] 10.2.\\
 Everything is done from command line, that means everything can be done over ssh on remote server.\\ Everything is done from command line, that means everything can be done over ssh on remote server.\\
 \\ \\
Line 10: Line 10:
 They can be installed using package manager **(Note: to install packages using package manager you need root permissions)**. They can be installed using package manager **(Note: to install packages using package manager you need root permissions)**.
   * **a. Gmake, tinyxml and libiconv**\\ Install them with command: **pkg install gmake tinyxml libiconv**   * **a. Gmake, tinyxml and libiconv**\\ Install them with command: **pkg install gmake tinyxml libiconv**
-  * **b. Lua**\\ When you want Lua 5.3 then install it with command: **pkg install lua53**\\ When you want Lua 5.2 then install it with command: **pkg install lua52**\\ When you want Lua 5.1 then install it with command: **pkg install lua51**+  * **b. Lua**\\ When you want Lua 5.3 then install it with command: **pkg install lua53**\\ When you want Lua 5.1 then install it with command: **pkg install lua51**
   * **c. Database support (optional)**\\ When you want **PostgreSQL** then install development files with command: **pkg install postgresql94-client**\\ When you want **SQLite** then install development files with command: **pkg install sqlite3**\\ When you want **MySQL** then install development files with command: **pkg install mysql56-client**\\ When you want **MariaDB** then install development files with command: **pkg install mariadb100-client**   * **c. Database support (optional)**\\ When you want **PostgreSQL** then install development files with command: **pkg install postgresql94-client**\\ When you want **SQLite** then install development files with command: **pkg install sqlite3**\\ When you want **MySQL** then install development files with command: **pkg install mysql56-client**\\ When you want **MariaDB** then install development files with command: **pkg install mariadb100-client**
 ==== 2. Downloading source and compile. ==== ==== 2. Downloading source and compile. ====
-  * **a. PtokaX source**\\ Download it with command: **fetch** <html><b>http://www.PtokaX.org/files/0.5.1.0-nix-src-b502.tgz</b></html>\\ Unpack downloaded archive with command: **tar -xf 0.5.1.0-nix-src-b502.tgz**\\ Now we have in actual directory new directory PtokaX. Go to that directory with command: **cd PtokaX**+  * **a. PtokaX source**\\ Download it with command: **fetch** <html><b>http://www.PtokaX.org/files/0.5.2.1-nix-src.tgz</b></html>\\ Unpack downloaded archive with command: **tar -xf 0.5.2.1-nix-src.tgz**\\ Now we have in actual directory new directory PtokaX. Go to that directory with command: **cd PtokaX**
   * **b. PtokaX compile**   * **b. PtokaX compile**
-    * **PtokaX without database support**\\ When you have Lua 5.3 then compile PtokaX with command: **gmake freebsd**\\ When you have Lua 5.2 then compile PtokaX with command: **gmake freebsd52**\\ When you have Lua 5.1 then compile PtokaX with command: **gmake freebsd51** +    * **PtokaX without database support**\\ When you have Lua 5.3 then compile PtokaX with command: **gmake freebsd**\\ When you have Lua 5.1 then compile PtokaX with command: **gmake freebsd51** 
-    * **PtokaX with PostgreSQL database support**\\ When you have Lua 5.3 then compile PtokaX with command: **gmake -f makefile-postgres freebsd**\\ When you have Lua 5.2 then compile PtokaX with command: **gmake -f makefile-postgres freebsd52**\\ When you have Lua 5.1 then compile PtokaX with command: **gmake -f makefile-postgres freebsd51** +    * **PtokaX with PostgreSQL database support**\\ When you have Lua 5.3 then compile PtokaX with command: **gmake -f makefile-postgres freebsd**\\ When you have Lua 5.1 then compile PtokaX with command: **gmake -f makefile-postgres freebsd51** 
-    * **PtokaX with SQLite database support**\\ When you have Lua 5.3 then compile PtokaX with command: **gmake -f makefile-sqlite freebsd**\\ When you have Lua 5.2 then compile PtokaX with command: **gmake -f makefile-sqlite freebsd52**\\ When you have Lua 5.1 then compile PtokaX with command: **gmake -f makefile-sqlite freebsd51** +    * **PtokaX with SQLite database support**\\ When you have Lua 5.3 then compile PtokaX with command: **gmake -f makefile-sqlite freebsd**\\ When you have Lua 5.1 then compile PtokaX with command: **gmake -f makefile-sqlite freebsd51** 
-    * **PtokaX with MySQL or MariaDB database support**\\ When you have Lua 5.3 then compile PtokaX with command: **gmake -f makefile-mysql freebsd**\\ When you have Lua 5.2 then compile PtokaX with command: **gmake -f makefile-mysql freebsd52**\\ When you have Lua 5.1 then compile PtokaX with command: **gmake -f makefile-mysql freebsd51**+    * **PtokaX with MySQL or MariaDB database support**\\ When you have Lua 5.3 then compile PtokaX with command: **gmake -f makefile-mysql freebsd**\\ When you have Lua 5.1 then compile PtokaX with command: **gmake -f makefile-mysql freebsd51**
 ==== 3. Setup and run. ==== ==== 3. Setup and run. ====
   * **a. **[[guides:unix_basic_setup|Basic setup.]]   * **a. **[[guides:unix_basic_setup|Basic setup.]]
   * **b. **[[guides:unix_run|How to run as console application or daemon.]]   * **b. **[[guides:unix_run|How to run as console application or daemon.]]
  
guides/freebsd.txt · Last modified: 13/04/2017 16:49 by ppk